🔍 CVE-2026-54757

7.8
CVSS Score
HIGH
2026-08-25
2026-09-09 21:09
✅ 완료

🇰🇷 한글 설명

Compliance-trestle(Trestle)의 특정 버전에서 서버 측 템플릿 주입(SSTI) 취약점이 발견되었습니다. 공격자가 조작된 마크다운 파일이나 YAML 값을 통해 Jinja2 표현식을 주입하면, Trestle 프로세스 권한으로 임의의 운영 체제 명령을 실행할 수 있습니다.

💡 쉬운 설명

프로그램이 문서를 읽어올 때 보안 검사가 부족하여, 문서 안에 숨겨진 악성 명령어를 실행할 수 있는 문제입니다. 이를 통해 해커가 사용자의 컴퓨터를 원격으로 조종할 위험이 있습니다.

🇺🇸 원문 (English)

Compliance-trestle (Trestle) is a Python SDK and command-line tool for managing OSCAL compliance documents. In versions before 3.12.4 and versions 4.0.0 through 4.0.3, Trestle is vulnerable to server-side template injection that can lead to remote code execution. This occurs because the MDCleanInclude and MDSectionInclude Jinja2 tags re-parse untrusted Markdown content as template source code using a non-sandboxed jinja2.Environment. An attacker who controls content that Trestle renders, such as a crafted workspace Markdown file, a third-party SSP document, or a YAML lookup-table value, can inject a Jinja2 expression that traverses Python object internals to execute arbitrary operating system commands in the context of the Trestle process. This issue is fixed in versions 3.12.4 and 4.1.0.

📍 영향받는 시스템

Compliance-trestle 3.12.4 미만 버전 및 4.0.0 ~ 4.0.3 버전

⚔️ 공격 벡터

조작된 마크다운 파일, 제3자 SSP 문서 또는 YAML 룩업 테이블 값을 통한 Jinja2 템플릿 주입

🛡️ 대응 방법

Trestle를 3.12.4 또는 4.1.0 이상의 최신 버전으로 업데이트하십시오.

🔧 검증 코드

출력된 버전이 3.12.4 미만이거나 4.0.0~4.0.3 범위에 해당하면 취약한 상태입니다.

Shell / Script
pip show trestle | grep Version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Python