🔍 CVE-2026-54789

7.5
CVSS Score
HIGH
2026-08-21
2026-10-15 19:10
✅ 완료

🇰🇷 한글 설명

Apache 2.x HTTP 서버용 OpenID Connect 모듈인 mod_auth_openidc의 state-cookie 파서에서 경계 외 읽기 및 1바이트 경계 외 쓰기 취약점이 발견되었습니다. 이 문제는 2.4.19.4 미만 버전에서 발생하며, 문자열 종료 지점 처리 미흡으로 인해 발생합니다. 최신 버전으로 업데이트하거나 WAF를 통해 잘못된 형식의 쿠키 헤더를 차단해야 합니다.

💡 쉬운 설명

웹사이트 로그인 기능을 도와주는 프로그램에서 데이터의 범위를 잘못 읽거나 쓰는 오류가 발생했습니다. 이로 인해 시스템 정보가 유출되거나 프로그램이 비정상적으로 작동할 위험이 있습니다.

🇺🇸 원문 (English)

mod_auth_openidc is an OpenID Certified authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. Prior to 2.4.19.4, an out-of-bounds read and a one-byte out-of-bounds write exist in the state-cookie parser of `mod_auth_openidc`. The issue is fixed in version 2.4.19.4 by stopping the scan at the string terminator so a value-less token is rejected. No in-product workarounds are available. As a stop-gap, an upstream reverse proxy or WAF that rejects or normalizes malformed `Cookie` headers (tokens lacking `=`) can reduce exposure, but upgrading is the recommended remediation.

📍 영향받는 시스템

mod_auth_openidc version < 2.4.19.4

⚔️ 공격 벡터

형식이 잘못된(값이 없는 토큰을 포함한) Cookie 헤더를 전송하여 발생

🛡️ 대응 방법

mod_auth_openidc를 2.4.19.4 이상 버전으로 업그레이드하거나 WAF를 통해 비정상적인 Cookie 헤더를 차단

🔧 검증 코드

출력된 버전 정보가 2.4.19.4 미만인지 확인하여 취약 여부를 판단합니다.

Shell / Script
apache2ctl -M | grep mod_auth_openidc && mod_auth_openidc --version 2>/dev/null || dpkg -l | grep mod-auth-openidc

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Apache HTTP Server