🔍 CVE-2026-56820

7.4
CVSS Score
HIGH
2026-07-21
2026-07-30 14:48
✅ 완료

🇰🇷 한글 설명

Netty 프레임워크의 OcspClient에서 OCSP 응답 내 CertificateID가 요청된 ID와 일치하는지 검증하지 않는 취약점이 발견되었습니다. 이로 인해 동일한 CA에서 발급된 다른 인증서의 유효한 응답을 재사용하여 인증서 폐기 확인 과정을 우회하는 재전송 공격이 가능합니다.

💡 쉬운 설명

인증서가 유효한지 확인하는 과정에서 다른 인증서의 확인서를 가로채어 사용하는 공격이 가능합니다. 이를 통해 폐기된 인증서를 마치 정상인 것처럼 속여 사용할 수 있습니다.

🇺🇸 원문 (English)

Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and prior to 4.1.135.Final, `OcspClient` does not validate that the `CertificateID` in an OCSP response matches the requested `CertificateID`, which can lead to replay attack. `OcspClient.validateResponse` accepts a legitimately signed `GOOD` status response for an unrelated certificate issued by the same CA, allowing bypass of revocation checks for another certificate. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

📍 영향받는 시스템

Netty 4.2.0.Final ~ 4.2.15.Final 및 4.1.135.Final 미만 버전

⚔️ 공격 벡터

동일한 CA에서 발급된 다른 인증서의 유효한 OCSP 응답을 재사용하는 재전송 공격(Replay Attack)

🛡️ 대응 방법

Netty 버전을 4.1.136.Final 또는 4.2.16.Final 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 결과에서 netty-handler의 버전이 4.1.136.Final 또는 4.2.16.Final보다 낮은지 확인합니다.

Shell / Script
mvn dependency:tree | grep -E 'netty-handler'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

💻 영향받는 소프트웨어

IBM WebSphere Application Server