🇰🇷 한글 설명
Asterisk는 오픈소스 PBX 및 텔레포니 툴킷입니다. Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 및 Certified Asterisk 20.7-cert11, 22.8-cert3 이전 버전에서는 PJSIP MWI 본문 파서의 버퍼 over-read로 인해, 인증된 공격자가 조작된 SIP NOTIFY 요청을 보내 Asterisk를 크래시시킬 수 있습니다. 공격자는 사용자명/비밀번호 또는 소스 IP 주소 일치를 통해 SIP 인증을 통과해야 합니다.
💡 쉬운 설명
전화 시스템 소프트웨어(Asterisk)에 결함이 있어, 로그인에 성공한 공격자가 특수하게 만든 메시지를 보내면 시스템이 멈출 수 있습니다. 공격을 하려면 먼저 인증을 통과해야 하므로 외부 익명 공격보다는 위험도가 낮습니다.
🇺🇸 원문 (English)
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may crash Asterisk through a buffer over-read in the `PJSIP MWI body parser` by sending a carefully crafted `SIP NOTIFY` request. The attacker must pass SIP authentication using either a username/password or `source IP address matching`. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
📍 영향받는 시스템
Asterisk 20.20.1 미만, 21.12.3 미만, 22.10.1 미만, 23.4.1 미만 및 Certified Asterisk 20.7-cert11 미만, 22.8-cert3 미만
⚔️ 공격 벡터
인증(사용자명/비밀번호 또는 허용된 소스 IP)을 통과한 공격자가 조작된 SIP NOTIFY 요청을 전송하여 PJSIP MWI 파서에서 버퍼 over-read를 유발
🛡️ 대응 방법
Asterisk를 20.20.1, 21.12.3, 22.10.1, 23.4.1 또는 Certified Asterisk 20.7-cert11, 22.8-cert3 이상으로 업데이트
🔧 검증 코드
출력된 버전이 해당 브랜치의 수정 버전(20.20.1 이상, 21.12.3 이상, 22.10.1 이상, 23.4.1 이상 또는 cert 버전) 이상이면 패치된 것이고, 미만이면 취약한 상태입니다.
asterisk -rx 'core show version' 2>/dev/null | head -n 1