🇰🇷 한글 설명
Asterisk 오픈소스 PBX 및 텔레포니 툴킷의 res_pjsip_pubsub 모듈에서, MWI NOTIFY 요청의 Message-Account 필드를 파싱할 때 경계 검사가 없는 sscanf 호출로 인해 스택 버퍼 오버플로가 발생합니다. 인증되지 않은 공격자가 조작된 패킷을 보내 전송 계층을 손상시키면 모든 SIP 기능이 영구적으로 비활성화될 수 있으며, 정상화를 위해서는 Asterisk 재시작이 필요합니다.
💡 쉬운 설명
전화 시스템 소프트웨어가 특정 형태의 악의적인 메시지를 잘못 처리하는 취약점입니다. 공격자가 인증 없이 이 메시지를 보내면 전화 서비스 전체가 멈추고, 관리자가 재시작해야 복구됩니다.
🇺🇸 원문 (English)
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unbounded `sscanf` in `res_pjsip_pubsub` when parsing the `MWI NOTIFY` `Message-Account` field may allow an unauthenticated attacker to send a carefully crafted packet that causes a stack buffer overflow and corrupts the underlying transport, permanently disabling all SIP functionality. An Asterisk restart is required to restore full operation. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
📍 영향받는 시스템
Asterisk 20.20.1 미만, 21.12.3 미만, 22.10.1 미만, 23.4.1 미만 및 Certified Asterisk 20.7-cert11 미만, 22.8-cert3 미만 버전
⚔️ 공격 벡터
인증 없이 네트워크에서 조작된 MWI NOTIFY SIP 패킷을 Asterisk 서버로 전송하여 스택 오버플로를 유발
🛡️ 대응 방법
Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 또는 Certified Asterisk 20.7-cert11, 22.8-cert3 이상으로 업데이트
🔧 검증 코드
출력된 버전이 해당 취약 버전 범위(20.20.1, 21.12.3, 22.10.1, 23.4.1 미만 또는 Certified 20.7-cert11, 22.8-cert3 미만)보다 낮으면 취약하며, 같거나 높으면 패치된 것입니다.
asterisk -V 2>/dev/null | grep -E 'Asterisk [0-9]+'