🇰🇷 한글 설명
Asterisk는 오픈소스 PBX 및 텔레포니 툴킷입니다. 20.20.1, 21.12.3, 22.10.1, 23.4.1 이전 버전 및 Certified Asterisk 20.7-cert11, 22.8-cert3 이전 버전에서, 인증된 공격자가 Codec2 디코더의 floor/ceil 샘플 수 불일치로 인한 범위 外 쓰기를 통해 힙 버퍼 오버플로우를 유발할 수 있습니다. codec_codec2 모듈이 로드되고 Codec2가 설정된 엔드포인트에서만 해당됩니다.
💡 쉬운 설명
전화 교환 시스템 사용자가 인증을 통과한 뒤, 특수하게 조작된 음성 데이터를 보내 시스템 메모리를 손상시킬 수 있는 취약점입니다. 이를 통해 서비스 중단이나 임의 코드 실행으로 이어질 수 있습니다.
🇺🇸 원문 (English)
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a heap buffer overflow through an out-of-bounds write in the `Codec2` decoder caused by a `floor/ceil sample-count mismatch`. The `codec_codec2` module must be loaded and `Codec2` must be configured on the attacked endpoint. The attacker must pass SIP authentication by username/password or `source IP address matching`, establish a call using `Codec2`, and send carefully crafted `Codec2` audio packets. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
📍 영향받는 시스템
Asterisk 20.20.1 미만, 21.12.3 미만, 22.10.1 미만, 23.4.1 미만 및 Certified Asterisk 20.7-cert11 미만, 22.8-cert3 미만 (codec_codec2 모듈 사용 시)
⚔️ 공격 벡터
사용자명/비밀번호 또는 IP 주소 기반 SIP 인증을 통과한 공격자가 Codec2로 통화를 맺고 조작된 Codec2 오디오 패킷을 전송
🛡️ 대응 방법
Asterisk를 20.20.1, 21.12.3, 22.10.1, 23.4.1 또는 Certified Asterisk 20.7-cert11, 22.8-cert3 이상으로 업그레이드하거나, codec_codec2 모듈을 비활성화
🔧 검증 코드
출력된 버전이 해당 수정 버전 이상이면 패치된 것이며, 미만이면 취약한 버전입니다.
asterisk -rx 'core show version' 2>/dev/null | head -1