🇰🇷 한글 설명
Asterisk 오픈소스 PBX 및 텔레포니 툴킷에서 AMI(Asterisk Manager Interface)의 NULL 포인터 역참조 취약점이 발견되었습니다. 인증되지 않은 공격자가 HTTP를 통해 Digest 인증을 사용할 때 Asterisk를 충돌시킬 수 있습니다. HTTP 서버, AMI, HTTP를 통한 AMI 접근이 모두 활성화되어야 하며, 기본값은 비활성화입니다.
💡 쉬운 설명
전화 교환 시스템(Asterisk)의 관리 기능에 결함이 있어, 외부인이 특정 조건에서 시스템을 강제로 멈추게 할 수 있습니다. 관리 웹 기능을 켠 경우에만 해당되며 기본 설정에서는 영향이 제한적입니다.
🇺🇸 원문 (English)
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, a NULL pointer dereference in the `Asterisk Manager Interface (AMI)` may allow an unauthenticated attacker to crash Asterisk when `Digest Authentication` is used via `HTTP`. The Asterisk `HTTP` web server, AMI, and AMI access via `HTTP` must all be enabled; each is disabled by default. The attacker must be able to connect to the `HTTP` server, which binds only to `127.0.0.1` by default even when enabled. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
📍 영향받는 시스템
Asterisk 20.20.1 미만, 21.12.3 미만, 22.10.1 미만, 23.4.1 미만 및 Certified Asterisk 20.7-cert11 미만, 22.8-cert3 미만
⚔️ 공격 벡터
AMI over HTTP가 활성화된 환경에서 공격자가 HTTP 서버에 접속해 Digest 인증 요청을 보내 NULL 포인터 역참조를 유발하여 서비스 거부(DoS)를 일으킴
🛡️ 대응 방법
Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 또는 Certified Asterisk 20.7-cert11, 22.8-cert3 이상으로 업그레이드하거나, AMI over HTTP 기능을 비활성화
🔧 검증 코드
출력된 버전이 취약 범위(20.20.1, 21.12.3, 22.10.1, 23.4.1 미만 또는 Certified 버전 미만)이면 취약하며, 해당 버전 이상이면 패치된 상태입니다.
📊 CVSS Vector String
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
💻 영향받는 소프트웨어
Microsoft Exchange Server