🔍 CVE-2026-59821

7.2
CVSS Score
HIGH
2026-07-08
2026-10-25 17:10
✅ 완료

🇰🇷 한글 설명

LiteLLM 1.82.0-stable 이전 버전에서 커스텀 코드 가드레일을 생성하거나 업데이트할 때 샌드박싱 및 검증이 제대로 적용되지 않는 취약점이 발견되었습니다. 이를 통해 권한이 있는 사용자가 임의의 파이썬 코드를 실행하여 프록시 환경 내의 비밀 정보를 탈취할 수 있습니다.

💡 쉬운 설명

LiteLLM이라는 AI 연결 도구에서 보안 검사가 누락된 부분이 있어, 권한을 가진 사용자가 악성 코드를 심을 수 있습니다. 이 코드가 실행되면 시스템에 저장된 중요한 비밀번호나 키를 훔쳐갈 위험이 있습니다.

🇺🇸 원문 (English)

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same sandboxing and validation used by the test endpoint, allowing a privileged user with access to create or update guardrails to submit custom Python code that executed in the LiteLLM proxy environment and could expose secrets available to the process. This issue is fixed in version 1.82.0-stable.

📍 영향받는 시스템

LiteLLM versions prior to 1.82.0-stable

⚔️ 공격 벡터

가드레일 생성/업데이트 경로를 통한 악성 파이썬 코드 주입 및 실행

🛡️ 대응 방법

LiteLLM을 1.82.0-stable 버전 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전이 1.82.0-stable보다 낮은지 확인하십시오.

Shell / Script
pip show litellm | grep Version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

litellm