🔍 CVE-2026-59823

5.3
CVSS Score
MEDIUM
2026-09-16
2026-09-30 17:43
✅ 완료

🇰🇷 한글 설명

LiteLLM Proxy 버전 1.83.9 미만에서 인증된 사용자가 user_config 요청 본문에 api_base를 포함하여 보안 검사를 우회할 수 있는 취약점이 발견되었습니다. 이를 통해 공격자는 서버 측 요청을 내부 또는 외부의 임의의 호스트로 리다이렉트하여 접근 권한이 없는 엔드포인트에 노출시킬 수 있습니다.

💡 쉬운 설명

정상적인 권한을 가진 사용자가 설정값을 조작하여 서버가 엉뚱한 곳으로 데이터를 보내게 만드는 공격입니다. 이를 통해 원래는 접근할 수 없는 내부 네트워크나 다른 서버에 접속할 위험이 있습니다.

🇺🇸 원문 (English)

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.9, an authenticated LiteLLM Proxy caller with a valid virtual key can place api_base inside the user_config request body to bypass is_request_body_safe, which blocks top-level api_base and base_url but previously did not inspect or reject user_config. Because user_config constructs the outbound router, the nested destination redirects a server-side request to an internal or external host selected by the caller and can expose endpoints the caller cannot otherwise access. This issue is fixed in version 1.83.9.

📍 영향받는 시스템

LiteLLM Proxy versions prior to 1.83.9

⚔️ 공격 벡터

인증된 사용자가 user_config 요청 본문에 api_base 필드를 삽입하여 서버 측 요청 리다이렉션 유도

🛡️ 대응 방법

LiteLLM Proxy를 버전 1.83.9 이상으로 업데이트

🔧 검증 코드

출력된 버전이 1.83.9 미만이면 취약한 상태입니다.

Shell / Script
pip show litellm | grep Version

📊 CVSS Vector String

CVSS Vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

💻 영향받는 소프트웨어

litellm