🇰🇷 한글 설명
Apache CloudStack의 시스템 VM 및 가상 라우터 진단 기능에서 명령 주입(Command Injection) 취약점이 발견되었습니다. 권한을 가진 인증된 사용자가 getDiagnosticsData 또는 runDiagnostics API를 호출하여 시스템 VM 및 가상 라우터에서 루트 권한으로 임의의 명령을 실행할 수 있습니다.
💡 쉬운 설명
관리자 권한을 가진 사용자가 시스템 진단 도구를 악용하여 서버에 몰래 명령을 내릴 수 있는 보안 약점입니다. 이를 통해 공격자는 서버의 제어권을 완전히 장악하거나 네트워크 내부로 침투할 수 있습니다.
🇺🇸 원문 (English)
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache CloudStack's run and get diagnostics functionality for the system VMs and virtual routers.
An authenticated user holding the permissions required to invoke either `getDiagnosticsData` or `runDiagnostics` can achieve arbitrary command execution on the system VM and/or Virtual Router instances, with commands running as root (or as the diagnostics-process user, at minimum). This represents a full compromise of the affected instance and, depending on network segmentation, may provide a foothold for lateral movement within the CloudStack-managed infrastructure, including access to guest network traffic handled by the compromised Virtual Router.
The getDiagnosticsData and runDiagnostics APIs are restricted to only Admin role accounts by default.
This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
📍 영향받는 시스템
Apache CloudStack 4.20.0.0 ~ 4.20.3.0 및 4.21.0.0 ~ 4.22.1.0
⚔️ 공격 벡터
인증된 사용자가 진단 관련 API(getDiagnosticsData, runDiagnostics)에 특수하게 조작된 명령어를 전달하여 실행
🛡️ 대응 방법
Apache CloudStack을 버전 4.20.3.1 또는 4.22.1.1 이상으로 업그레이드하십시오.
🔧 검증 코드
설치된 CloudStack의 버전을 확인하여 취약한 버전 범위에 해당하는지 대조합니다.
rpm -q cloudstack-server || dpkg -l | grep cloudstack
📊 CVSS Vector String
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
💻 영향받는 소프트웨어
VMware Telco Cloud Infrastructure