🔍 CVE-2026-63292

7.5
CVSS Score
HIGH
2026-10-01
2026-10-05 17:47
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server 2.4.68 이하 버전의 mod_vhost_alias 모듈에서 스택 기반 버퍼 오버플로우 취약점이 발견되었습니다. 공격자가 8192바이트를 초과하는 Host 헤더를 포함한 HTTP 요청을 보내면 서비스 거부(DoS)를 일으키거나 임의의 코드를 실행할 수 있습니다. 이는 VirtualDocumentRoot가 호스트 이름 형식 지정자를 사용하고 LimitRequestFieldSize 설정이 기본값보다 높을 때 발생합니다.

💡 쉬운 설명

웹 서버에 너무 긴 이름이 담긴 요청을 보내서 서버를 멈추게 하거나 해커가 마음대로 조종할 수 있는 약점입니다. 서버 설정이 특정 조건일 때 발생하며, 서버가 비정상적으로 작동할 수 있습니다.

🇺🇸 원문 (English)

Stack-based buffer overflow in mod_vhost_alias in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows a remote client to cause a denial of service or potentially execute arbitrary code via an HTTP request with a Host header exceeding 8192 bytes when VirtualDocumentRoot uses a hostname format specifier and LimitRequestFieldSize is raised above the default. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.68 및 그 이전 모든 버전

⚔️ 공격 벡터

8192바이트를 초과하는 Host 헤더를 포함한 특수하게 조작된 HTTP 요청 전송

🛡️ 대응 방법

Apache HTTP Server를 취약점이 해결된 2.4.69 버전 이상으로 업그레이드하십시오.

🔧 검증 코드

출력된 버전이 2.4.68 이하인 경우 해당 취약점에 노출된 상태입니다.

Shell / Script
apache2 -v 2>/dev/null || httpd -v 2>/dev/null | grep -E 'Apache/2\.[0-4]\.[0-6][0-8]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Apache HTTP Server
🇰🇷 KISA(한국인터넷진흥원) 보안 권고 이 CVE에 대한 한국 공식 권고 (1건)
Apache 제품 보안 업데이트 권고 P4
📅 2026-10-06 · sec_notice
Apache HTTP Server에서 버퍼 오버플로우, 인증 우회 등 다수의 보안 취약점이 발견되었습니다. 해당 제품의 2.4.69 미만 버전을 사용하는 사용자는 보안 위협을 방지하기 위해 최신 버전인 2.4.69 이상으로 업데이트해야 합니다.
KISA 원문 →