🔍 CVE-2026-63498

8.7
CVSS Score
HIGH
2026-09-24
2026-09-29 16:50
✅ 완료

🇰🇷 한글 설명

Snipe-IT 8.7.0 미만 버전에서 인증된 사용자가 XML 및 XSLT 파일을 업로드하고 이를 요청할 수 있는 취약점이 존재합니다. API 엔드포인트가 안전한 인라인 허용 목록을 적용하지 않아, 공격자가 조작한 XML 스타일시트를 통해 Snipe-IT 도메인 내에서 자바스크립트를 실행할 수 있습니다. 이를 통해 피해자의 권한으로 동일 출처 데이터를 읽거나 인증된 작업을 수행할 수 있습니다.

💡 쉬운 설명

해커가 악성 코드가 담긴 파일을 업로드한 뒤, 관리자가 그 파일을 열게 유도하여 관리자의 권한을 탈취하는 공격입니다. 관리자가 파일을 클릭하는 순간, 해커가 심어놓은 명령어가 관리자의 계정으로 몰래 실행됩니다.

🇺🇸 원문 (English)

Snipe-IT is an IT asset/license management system. Prior to 8.7.0, the uploaded-files API endpoint GET /api/v1/{object_type}/{id}/files/{file_id} allows an authenticated user with file-management access to upload XML and XSLT attachments and request them with the inline=true parameter. The app/Http/Controllers/Api/UploadedFilesController.php show() path does not apply the safe-inline allowlist used by the equivalent web controller, so the browser can process an attacker-controlled xml-stylesheet reference and execute JavaScript generated by the stylesheet in the Snipe-IT origin. A victim who is authorized to view the object must open the attachment URL, after which the script can read same-origin data and perform authenticated actions with the victim's privileges. This issue is fixed in version 8.7.0.

📍 영향받는 시스템

Snipe-IT 8.7.0 미만 버전

⚔️ 공격 벡터

인증된 사용자가 악성 XML/XSLT 파일을 업로드한 후, 피해자가 해당 파일 URL을 열도록 유도하여 XSS 실행

🛡️ 대응 방법

Snipe-IT를 최신 보안 패치가 적용된 8.7.0 버전 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 정보가 8.7.0 미만이면 취약한 상태이며, 8.7.0 이상이면 안전합니다.

Shell / Script
curl -s http://<target-ip>/api/v1/version | grep -E '8\.[7-9]|9\.' || echo 'Vulnerable'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

💻 영향받는 소프트웨어

Cisco Integrated Management Controller