🇰🇷 한글 설명
Apache Camel의 Knative 컴포넌트에서 구조화된 콘텐츠 모드(application/cloudevents+json) 사용 시 CloudEvent 확장 필드가 검증 없이 Camel 헤더로 복사되는 취약점입니다. 공격자는 이를 통해 Camel 내부 헤더를 주입하여 SSRF, 경로 탐색 또는 메시지 전달 리디렉션을 수행할 수 있습니다.
💡 쉬운 설명
데이터를 주고받는 과정에서 검증되지 않은 정보가 시스템의 중요한 설정값으로 잘못 입력되는 문제입니다. 이를 통해 해커가 서버가 엉뚱한 곳으로 데이터를 보내게 하거나 시스템 내부 파일에 접근하도록 조작할 수 있습니다.
🇺🇸 원문 (English)
Improper Input Validation, Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in Apache Camel Knative component
The Knative consumer in camel-knative maps inbound CloudEvent attributes onto Camel message headers. In binary content mode the HTTP-header path filters Camel-internal headers through KnativeHttpHeaderFilterStrategy, but in structured content mode (Content-Type application/cloudevents+json) the CloudEvent extension fields are read directly from the JSON body and every extension key is copied into the Exchange headers without applying any HeaderFilterStrategy (CloudEventProcessors, spec versions 1.0, 1.0.1 and 1.0.2). As a result, an unauthenticated attacker can inject Camel-internal headers (e.g. CamelHttpUri, CamelHttpPath, CamelFileName) via a structured-mode CloudEvent request, matched case-insensitively against Camel's header map. When a route forwards messages from a Knative consumer to a header-driven component such as camel-http or camel-file, the injected headers override configured values, enabling server-side request forgery (SSRF), path traversal or message-dispatch redirection depending on the route. This is an incomplete fix of the inbound header filtering previously added for the binary content-mode path, and is the same pattern addressed in camel-cxf/camel-knative (CVE-2026-47323), camel-undertow (CVE-2025-30177), the broader incoming-header filter (CVE-2025-27636 and CVE-2025-29891), and the non-HTTP strategies (CVE-2026-40453).
This issue affects Apache Camel: from 3.15.0 before 4.14.9, from 4.15.0 before 4.18.4, from 4.19.0 before 4.21.0.
Users are recommended to upgrade to version 4.22.0, which fixes the issue. If users are on the 4.18.x LTS releases stream, then they are suggested to upgrade to 4.18.4. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.9. The non-LTS releases 4.15.0 through 4.17.0 and 4.19.0 through 4.21.0 are affected but do not receive a maintenance fix; users on those versions should upgrade to 4.18.4 or 4.22.0.
📍 영향받는 시스템
Apache Camel 3.15.0 < 4.14.9, 4.15.0 < 4.18.4, 4.19.0 < 4.21.0
⚔️ 공격 벡터
인증되지 않은 공격자가 구조화된 CloudEvent 요청의 JSON 바디에 악의적인 확장 필드를 포함하여 전송
🛡️ 대응 방법
Apache Camel을 4.22.0, 4.18.4 또는 4.14.9 이상의 보안 패치 버전으로 업그레이드
🔧 검증 코드
출력된 Apache Camel의 버전을 확인하여 취약한 버전 범위에 해당하는지 체크합니다.
mvn dependency:list | grep 'camel-core' | awk '{print $4}'