🔍 CVE-2026-63626

8.8
CVSS Score
HIGH
2026-10-14
2026-10-16 20:04
✅ 완료

🇰🇷 한글 설명

Mongoose 임베디드 웹 서버의 ppp_handle_ipv6cp() 함수에서 16비트 IPv6CP 길이 필드를 검증하지 않는 취약점이 발견되었습니다. 공격자가 조작된 길이를 가진 Configure-Request를 전송하면 메모리 경계를 넘어 읽거나 쓰는 버퍼 오버플로우가 발생할 수 있습니다. 이로 인해 인접한 힙 데이터가 노출되거나 이벤트 루프가 중단될 수 있습니다.

💡 쉬운 설명

네트워크 연결 과정에서 데이터의 길이를 제대로 확인하지 않아 발생하는 보안 결함입니다. 해커가 가짜 데이터를 보내 시스템의 메모리를 훔쳐보거나 프로그램을 멈추게 할 수 있습니다.

🇺🇸 원문 (English)

Mongoose is an embedded web server and network library. Prior to 7.23, ppp_handle_ipv6cp() in src/l2_ppp.c trusts the 16-bit IPv6CP len field without checking it against the received payload size. On a PPP or PPPoE link using MG_ENABLE_TCPIP and MG_ENABLE_IPV6, an unauthenticated adjacent peer can complete the required LCP exchange and send a short Configure-Request with an oversized length, causing ppp_tx_frame() to read beyond recv_queue.buf and write beyond tx.buf. The same length misuse can also expose adjacent heap bytes in a reply or hang the event loop through find_opt(). This issue is fixed in version 7.23.

📍 영향받는 시스템

Mongoose library versions prior to 7.23 (using MG_ENABLE_TCPIP and MG_ENABLE_IPV6)

⚔️ 공격 벡터

PPP 또는 PPPoE 링크를 사용하는 인접한 공격자가 조작된 IPv6CP Configure-Request 패킷을 전송

🛡️ 대응 방법

Mongoose 라이브러리를 버전 7.23 이상으로 업데이트

🔧 검증 코드

출력된 MG_VERSION 값이 7.23 미만이면 취약한 버전이 설치되어 있는 것입니다.

Shell / Script
grep -r "Mongoose" /path/to/your/project/src | xargs grep -E "#define MG_VERSION" 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Microsoft Exchange Server