🔍 CVE-2026-63686

7.5
CVSS Score
HIGH
2026-10-01
2026-10-05 17:46
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server 2.4.69 미만 버전의 mod_xml2enc 모듈에서 NULL 포인터 역참조 취약점이 발견되었습니다. 신뢰할 수 없는 백엔드 서버가 문자셋 변환이 부분적으로 성공하다 실패하는 응답을 프록시로 전달할 경우 서비스 거부(DoS) 상태를 유발할 수 있습니다.

💡 쉬운 설명

웹 서버가 외부 서버로부터 받은 데이터를 처리하는 과정에서 오류가 발생하여 서버가 멈춰버릴 수 있는 문제입니다. 공격자가 특수한 데이터를 보내면 서버가 정상적으로 작동하지 않게 됩니다.

🇺🇸 원문 (English)

A NULL pointer dereference in mod_xml2enc in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an untrusted backend server to cause a denial of service via a proxied response with a charset whose conversion partially succeeds then fails. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.69 미만 모든 플랫폼 버전

⚔️ 공격 벡터

신뢰할 수 없는 백엔드 서버가 조작된 문자셋을 포함한 프록시 응답을 전송하여 발생

🛡️ 대응 방법

Apache HTTP Server를 최신 버전인 2.4.69 이상으로 업그레이드하십시오.

🔧 검증 코드

출력된 버전이 2.4.69 미만인 경우 해당 취약점에 노출된 상태입니다.

Shell / Script
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -E 'Apache/2\.[0-4]\.[0-68]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Apache HTTP Server
🇰🇷 KISA(한국인터넷진흥원) 보안 권고 이 CVE에 대한 한국 공식 권고 (1건)
Apache 제품 보안 업데이트 권고 P4
📅 2026-10-06 · sec_notice
Apache HTTP Server에서 버퍼 오버플로우, 인증 우회 등 다수의 보안 취약점이 발견되었습니다. 해당 제품의 2.4.69 미만 버전을 사용하는 사용자는 보안 위협을 방지하기 위해 최신 버전인 2.4.69 이상으로 업데이트해야 합니다.
KISA 원문 →