🇰🇷 한글 설명
webpack-dev-server 5.2.3 이하 버전에서 HTTP를 통해 소스 코드가 교차 출처로 노출되는 취약점이 발견되었습니다. 공격자는 개발자가 방문한 악성 사이트를 통해 로컬 개발 서버의 번들링된 소스 코드를 탈취할 수 있습니다. 이를 해결하기 위해 Cross-Origin-Resource-Policy 헤더를 사용하는 5.2.4 이상 버전으로 업데이트가 필요합니다.
💡 쉬운 설명
개발용 서버를 보안이 취약한 HTTP 방식으로 사용할 때, 나쁜 사이트에 접속만 해도 내 컴퓨터에서 돌아가는 소스 코드가 유출될 수 있는 문제입니다. 최신 버전으로 업데이트하면 이 위험을 막을 수 있습니다.
🇺🇸 원문 (English)
webpack-dev-server versions up to and including 5.2.3 are vulnerable to cross-origin source code exposure when serving over a non-potentially trustworthy origin such as plain HTTP. The previous fix relied on the Sec-Fetch-Mode and Sec-Fetch-Site request headers, which browsers omit for non-trustworthy origins, allowing a malicious site to load the bundled source as a script and read it across origins. Impact: an attacker controlling a website visited by a developer running webpack-dev-server can recover the application source code when the dev server runs over HTTP at a guessable host and port. Chromium based browsers from Chrome 142 onward are not affected due to local network access restrictions. Upgrade to webpack-dev-server 5.2.4 or later, which sets Cross-Origin-Resource-Policy: same-origin on responses.
📍 영향받는 시스템
webpack-dev-server versions up to and including 5.2.3
⚔️ 공격 벡터
HTTP 환경에서 실행 중인 개발 서버를 악성 웹사이트가 스크립트로 로드하여 소스 코드를 읽어가는 방식
🛡️ 대응 방법
webpack-dev-server를 5.2.4 버전 이상으로 업그레이드하십시오.
🔧 검증 코드
출력된 결과에서 webpack-dev-server의 버전을 확인하여 5.2.4 미만인지 체크합니다.
npm list webpack-dev-server
📊 CVSS Vector String
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
💻 영향받는 소프트웨어
IBM WebSphere Application Server