🔍 CVE-2026-64657

8.4
CVSS Score
HIGH
2026-08-17
2026-09-08 21:03
✅ 완료

🇰🇷 한글 설명

Budibase 3.39.19 미만 버전의 PostgreSQL 데이터 소스 커넥터에서 발생하는 취약점입니다. 인증된 관리자가 스키마 설정 필드에 이스케이프되지 않은 큰따옴표를 삽입하여 SET search_path 문에 조작된 값을 주입할 수 있으며, 이를 통해 임의의 SQL을 실행할 수 있습니다.

💡 쉬운 설명

관리자 권한을 가진 사용자가 데이터베이스 설정 값을 교묘하게 조작하여, 원래 의도하지 않은 위험한 명령어를 데이터베이스에 실행시킬 수 있는 보안 결함입니다. 이로 인해 데이터베이스 내의 중요한 정보가 유출되거나 변조될 위험이 있습니다.

🇺🇸 원문 (English)

Budibase is an open-source low-code platform. Prior to 3.39.19, the PostgreSQL datasource connector in packages/server/src/integrations/postgres.ts interpolates the user-controlled schema configuration field into a SET search_path statement without escaping embedded double quotes, allowing an authenticated administrator who saves or tests the datasource to execute arbitrary SQL through the simple query protocol. This issue is fixed in version 3.39.19.

📍 영향받는 시스템

Budibase versions prior to 3.39.19

⚔️ 공격 벡터

인증된 관리자가 PostgreSQL 데이터 소스의 스키마 설정 필드에 특수하게 조작된 SQL 구문을 입력하여 공격

🛡️ 대응 방법

Budibase를 최신 버전인 3.39.19 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 3.39.19보다 낮으면 취약한 상태이며, 3.39.19 이상이면 안전합니다.

Shell / Script
npm list -g budibase | grep -E 'budibase@([0-9]+\.[0-9]+\.[0-9]+)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H

💻 영향받는 소프트웨어

PostgreSQL