🔍 CVE-2026-6637

8.8
CVSS Score
HIGH
2026-05-14
2026-05-18 15:05
✅ 완료

🇰🇷 한글 설명

PostgreSQL의 refint 모듈에 있는 스택 버퍼 오버플로우 취약점으로, 권한 없는 데이터베이스 사용자가 데이터베이스를 실행하는 OS 사용자 권한으로 임의 코드를 실행할 수 있습니다. 사용자 제어 열이 refint 캐스케이드 기본 키로 선언되고 업데이트를 용이하게 하는 애플리케이션의 경우, SQL 주입으로 기본 키 업데이트 권한의 데이터베이스 사용자 권한으로 임의 SQL을 실행할 수 있습니다.

💡 쉬운 설명

PostgreSQL 데이터베이스에 심각한 보안 결함이 있어서 낮은 권한의 사용자가 전체 컴퓨터 시스템을 장악할 수 있습니다. 웹 애플리케이션에서 사용자 입력을 받아서 처리할 때 이 취약점을 통해 공격받을 수 있습니다.

🇺🇸 원문 (English)

Stack buffer overflow in PostgreSQL module "refint" allows an unprivileged database user to execute arbitrary code as the operating system user running the database. A distinct attack is possible if the application declares a user-controlled column as a "refint" cascade primary key and facilitates user-controlled updates to that column. In that case, a SQL injection allows a primary key update value provider to execute arbitrary SQL as the database user performing the primary key update. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

📍 영향받는 시스템

PostgreSQL 14.23 미만, 15.18 미만, 16.14 미만, 17.10 미만, 18.4 미만 모든 버전

⚔️ 공격 벡터

권한 없는 데이터베이스 사용자가 refint 모듈 버퍼 오버플로우를 악용하거나 사용자 제어 열의 SQL 주입으로 공격

🛡️ 대응 방법

PostgreSQL을 14.23, 15.18, 16.14, 17.10, 18.4 이상의 보안 패치 버전으로 즉시 업그레이드

🔧 검증 코드

VULNERABLE이 출력되면 영향받는 버전이므로 즉시 패치 필요, PATCHED이면 안전한 버전

Shell / Script
psql --version | grep -oE '[0-9]+\.[0-9]+' | awk '{if ($1 < 14.23 || ($1 >= 15 && $1 < 15.18) || ($1 >= 16 && $1 < 16.14) || ($1 >= 17 && $1 < 17.10) || ($1 >= 18 && $1 < 18.4)) print "VULNERABLE"; else print "PATCHED"}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PostgreSQL
🇰🇷 KISA(한국인터넷진흥원) 보안 권고 이 CVE에 대한 한국 공식 권고 (1건)
PostgreSQL 제품 보안 업데이트 권고 P4
📅 2026-09-10 · sec_notice
PostgreSQL 제품에서 SQL Injection, Buffer Overflow 등 다양한 보안 취약점이 발견되었습니다. 해당 제품을 사용하는 사용자는 데이터 유출 및 시스템 권한 탈취를 방지하기 위해 최신 보안 버전으로 업데이트해야 합니다.
KISA 원문 →