🔍 CVE-2026-67320

7.5
CVSS Score
HIGH
2026-08-01
2026-09-01 15:39
✅ 완료

🇰🇷 한글 설명

Node.js 환경에서 axios의 HTTP 어댑터 사용 시, 요청 설정이 프로토타입 오염을 통해 공격자가 제어하는 프록시로 라우팅될 수 있는 취약점입니다. 인터셉터에서 설정 객체를 복사하는 과정에서 axios의 보안 조치가 해제되어, Object.prototype.proxy를 오염시킨 공격자가 HTTP 요청의 인증 헤더 및 본문 데이터를 탈취할 수 있습니다.

💡 쉬운 설명

프로그램의 설정값이 조작되어 사용자의 데이터가 해커가 만든 가짜 통로(프록시)를 거쳐가게 만드는 보안 결함입니다. 이 과정에서 아이디, 비밀번호, 중요한 메시지 내용이 해커에게 노출될 위험이 있습니다.

🇺🇸 원문 (English)

axios in a Node.js deployment using the HTTP adapter can route requests through an attacker-controlled proxy. axios hardens merged request configuration by creating a null-prototype object, but request interceptors run after the merge; a common immutable interceptor pattern such as {...config} or Object.assign({}, config) converts the hardened config back into a regular object. axios then dispatches that object without re-hardening it, and the Node HTTP adapter reads config.proxy through the prototype chain. If an attacker can pollute Object.prototype.proxy, affected requests can be routed through an attacker-controlled proxy. For plaintext HTTP requests, the proxy can observe Authorization headers, Basic auth from config.auth, method, absolute URL, Host, and request body, and can return its own response. This does not establish browser impact or HTTPS header/body disclosure under normal TLS validation. Affected versions are >=0.31.1 (fixed in 0.33.0) and >=1.15.2 (fixed in 1.18.0).

📍 영향받는 시스템

axios >=0.31.1 (0.33.0 미만) 및 >=1.15.2 (1.18.0 미만)

⚔️ 공격 벡터

Object.prototype.proxy를 오염시켜 axios 요청이 공격자의 프록시 서버를 경유하도록 유도

🛡️ 대응 방법

axios 버전을 0.33.0 또는 1.18.0 이상으로 업데이트

🔧 검증 코드

출력된 결과에 취약한 버전 범위가 포함되어 있다면 업데이트가 필요합니다.

Shell / Script
npm list axios | grep -E 'axios@(0\[\.\d+\.\d+\|1\.(31\.[1-5]|15\.[2-17]|16\.|17\.)\)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

Node.js