🔍 CVE-2026-67422

7.5
CVSS Score
HIGH
2026-08-06
2026-10-24 16:10
✅ 완료

🇰🇷 한글 설명

pymdown-extensions 11.0 이하 버전의 caret, tilde, betterem, magiclink 인라인 프로세서는 정규표현식의 내용 그룹이 입력을 지수적으로 많은 방식으로 분할할 수 있어 치명적인 백트래킹이 발생합니다. 이로 인해 50바이트 미만의 악성 Markdown 한 줄만으로도 렌더링 스레드의 CPU 사용량이 입력 길이에 따라 지수적으로 증가하여 서비스 거부(DoS)가 발생할 수 있습니다. 11.0.1 버전에서 수정되었습니다.

💡 쉬운 설명

사용자가 입력한 아주 짧은 Markdown 문장 하나가 서버를 과도하게 바쁘게 만들어 웹사이트가 느려지거나 멈출 수 있습니다. 해당 라이브러리를 최신 버전으로 업데이트하면 이 문제를 해결할 수 있습니다.

🇺🇸 원문 (English)

pymdown-extensions is a collection of extensions for the Python Markdown library. In versions up to and including 11.0, four inline processors (caret, tilde, betterem, and magiclink) use regular expressions whose content groups can partition a run of; in exponentially many ways, causing catastrophic backtracking. As a result, a single untrusted Markdown line under 50 bytes rendered with markdown.markdown() in each extension's default configuration drives the rendering thread into unbounded CPU usage that grows exponentially with input length, enabling an unauthenticated remote attacker who can submit Markdown to cause denial of service. The exposure is concrete for web applications that render user-supplied Markdown (comments, wikis, issue bodies, live preview), including any app using pymdownx.extra which bundles the vulnerable betterem default, as well as hosted docs/CI systems that build untrusted Markdown. The issue has been fixed in version 11.0.1.

📍 영향받는 시스템

pymdown-extensions 11.0 이하 버전 (pymdownx.extra 포함), 수정 버전 11.0.1

⚔️ 공격 벡터

인증 없이 댓글, 위키, 이슈 본문 등 Markdown을 받는 입력란에 50바이트 미만의 악성 Markdown 한 줄을 제출

🛡️ 대응 방법

pymdown-extensions를 11.0.1 이상으로 업그레이드 (pip install -U "pymdown-extensions>=11.0.1")

🔧 검증 코드

출력된 Version 값이 11.0.1 이상이면 취약점이 수정된 것이며, 11.0 이하이면 즉시 업그레이드가 필요합니다.

Shell / Script
pip show pymdown-extensions 2>/dev/null | grep -i '^version'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Python