🔍 CVE-2026-70472

8.8
CVSS Score
HIGH
2026-08-04
2026-10-24 15:10
✅ 완료

🇰🇷 한글 설명

Flowise 3.1.3 미만 버전에서 openai-assistants-vector-store 엔드포인트가 사용자 작업 공간(workspace) 소유 여부를 확인하지 않고 자격 증명을 로드하는 취약점이 발견되었습니다. 공격자가 타인의 자격 증명 ID를 알 경우, 해당 사용자의 OpenAI 키를 사용하여 벡터 스토어 및 파일을 조작하거나 비용을 발생시킬 수 있습니다.

💡 쉬운 설명

Flowise라는 도구에서 다른 사용자의 비밀 열쇠를 몰래 가져다 쓸 수 있는 보안 구멍이 발견되었습니다. 이를 통해 남의 데이터를 읽거나 지우고, 남의 돈으로 AI 서비스를 이용할 수 있습니다.

🇺🇸 원문 (English)

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, Flowise openai-assistants-vector-store endpoints accept a client-controlled credential parameter and load credentials by id without checking whether that credential belongs to the caller workspace. Route permissions assistants:* only check feature access. The controller passes req.query.credential straight to the service, and the service uses findOneBy({ id: credentialId }), decrypts the credential, and calls OpenAI APIs without a workspaceId check. If an attacker knows another workspace credentialId, the attacker can use that workspace OpenAI key, read, modify, or delete victim vector stores and files, cause billing impact on the victim OpenAI account, and violate multi-tenant boundaries. This issue is fixed in version 3.1.3.

📍 영향받는 시스템

Flowise version < 3.1.3

⚔️ 공격 벡터

공격자가 타인의 credentialId를 쿼리 파라미터로 전달하여 권한 검증 없이 자격 증명을 호출

🛡️ 대응 방법

Flowise를 최신 버전인 3.1.3 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전이 3.1.3 미만(예: 3.1.2 이하)이면 취약한 상태입니다.

Shell / Script
npm list flowise | grep -E 'flowise@3\.[0-1]\.'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Spring AI Vector Store