🔍 CVE-2026-73076

7.8
CVSS Score
HIGH
2026-08-11
2026-10-06 19:39
✅ 완료

🇰🇷 한글 설명

Vim 9.2.0847 미만 버전의 runtime/autoload/vimball.vim에서 발생하는 취약점입니다. 조작된 .VimballRecord를 포함한 vimball 멤버를 통해 공격자가 선택한 명령어를 설치 기록에 덮어쓸 수 있으며, vimball#RmVimball() 실행 시 사용자 권한으로 운영체제 명령어가 실행됩니다.

💡 쉬운 설명

악의적으로 만들어진 Vim 파일을 열 때, 공격자가 심어놓은 명령어가 내 컴퓨터에서 몰래 실행될 수 있는 보안 약점입니다. 사용자가 의도하지 않은 프로그램 설치나 파일 삭제가 발생할 수 있습니다.

🇺🇸 원문 (English)

Vim is an open source, command line text editor. Prior to 9.2.0847, runtime/autoload/vimball.vim allows a crafted vimball member named .VimballRecord to overwrite the installation record with attacker-chosen commands. When vimball#RmVimball() later processes the matching record entry, the stored Ex commands, including operating-system commands invoked through :!, execute with the privileges of the user running Vim. This issue is fixed in version 9.2.0847.

📍 영향받는 시스템

Vim 9.2.0847 미만 모든 버전

⚔️ 공격 벡터

조작된 .VimballRecord가 포함된 vimball 파일을 사용하여 vimball#RmVimball() 함수를 호출함

🛡️ 대응 방법

Vim을 최신 버전인 9.2.0847 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 9.2.0847보다 낮으면 취약한 상태입니다.

Shell / Script
vim --version | head -n 1 | grep -oE 'Vim (9\.[0-9]+(\.[0-9]+)?)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Magento Open Source