🔍 CVE-2026-73077

7.8
CVSS Score
HIGH
2026-08-11
2026-10-06 19:34
✅ 완료

🇰🇷 한글 설명

Vim 9.2.0839 이전 버전의 특정 파일 유형 플러그인(sh, zsh, ps1)에서 발생하는 취약점입니다. 공격자가 제어하는 Visual-mode 선택 영역이 쉘 명령어로 전달될 때 특수 문자가 제대로 필터링되지 않아, 사용자의 권한으로 임의의 운영체제 명령어가 실행될 수 있습니다.

💡 쉬운 설명

Vim 편집기에서 특정 명령을 사용할 때, 공격자가 입력한 악성 코드가 명령어로 오인되어 컴퓨터에서 실행될 수 있는 문제입니다. 이를 통해 해커가 사용자의 컴퓨터를 마음대로 조작할 수 있습니다.

🇺🇸 원문 (English)

Vim is an open source, command line text editor. Prior to 9.2.0839, the runtime/ftplugin/sh.vim, runtime/ftplugin/zsh.vim, and runtime/ftplugin/ps1.vim filetype plugins pass attacker-controlled Visual-mode selections from K through keywordprg commands without safely separating shell arguments. fnameescape() and PATH_ESC_CHARS do not neutralize shell metacharacters before ShKeywordPrg, ZshKeywordPrg, or GetHelp invokes bash, zsh, or PowerShell, allowing arbitrary operating-system commands to execute with the privileges of the user running Vim. This issue is fixed in version 9.2.0839.

📍 영향받는 시스템

Vim 9.2.0839 미만 버전 (sh, zsh, ps1 플러그인 사용 시)

⚔️ 공격 벡터

Visual-mode에서 특정 키워드를 선택한 후 명령어를 실행하여 쉘 메타문자를 주입하는 방식

🛡️ 대응 방법

Vim을 최신 버전인 9.2.0839 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 9.2.0839보다 낮으면 취약한 상태입니다.

Shell / Script
vim --version | grep -E 'Vim (9\.[0-9]{2}\.[0-9]{4})' | awk '{print $3}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Magento Open Source