🔍 CVE-2026-73078

8.8
CVSS Score
HIGH
2026-08-11
2026-10-06 19:25
✅ 완료

🇰🇷 한글 설명

Vim 9.2.0840 미만 버전에서 netrw 플러그인이 디렉토리 경로를 처리할 때 명령 구분자(|)나 작은따옴표를 제대로 중화하지 못하는 취약점이 발견되었습니다. 공격자가 조작된 경로를 포함한 디렉토리를 탐색하거나 북마크하게 유도하면, GUI Vim에서 임의의 Ex 명령 및 운영체제 명령이 실행될 수 있습니다.

💡 쉬운 설명

Vim 편집기에서 특정 폴더 이름을 열 때, 폴더 이름에 숨겨진 악성 명령어가 함께 실행될 수 있는 보안 결함입니다. 공격자가 만든 특수 폴더를 클릭하기만 해도 컴퓨터에 해로운 명령을 내릴 수 있습니다.

🇺🇸 원문 (English)

Vim is an open source, command line text editor. Prior to 9.2.0840, runtime/plugin/netrwPlugin.vim loads netrw and runtime/pack/dist/opt/netrw/autoload/netrw.vim constructs Bookmarks, History, and Targets menu entries by interpolating attacker-controlled directory paths into executed :menu commands. s:NetrwBookmarkMenu(), s:NetrwTgtMenu(), g:netrw_menu_escape, EX_TRLBAR, and netrw#MakeTgt() fail to neutralize the | command separator or single quotes at five construction sites, allowing a crafted path browsed or bookmarked in GUI Vim to execute arbitrary Ex and operating-system commands. This issue is fixed in version 9.2.0840.

📍 영향받는 시스템

Vim 9.2.0840 미만 버전 (netrw 플러그인 사용 시)

⚔️ 공격 벡터

조작된 디렉토리 경로를 포함한 북마크 또는 탐색을 통한 명령 주입 (Command Injection)

🛡️ 대응 방법

Vim을 최신 버전인 9.2.0840 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 9.2.0840보다 낮으면 취약한 상태이며, 9.2.0840 이상이면 안전합니다.

Shell / Script
vim --version | head -n 1 | grep -oE 'Vim (9\.[0-9]+(\.[0-9]+)?|10\.[0-9]+)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Magento Open Source