🔍 CVE-2026-7377

8.7
CVSS Score
HIGH
2026-05-14
2026-05-16 03:33
✅ 완료

🇰🇷 한글 설명

GitLab EE의 커스터마이징 가능한 분석 대시보드에서 입력값 검증 부족으로 인해 인증된 사용자가 다른 사용자의 브라우저에서 임의의 JavaScript를 실행할 수 있는 Stored XSS 취약점입니다. 18.7 이상 18.9.7 미만, 18.10 이상 18.10.6 미만, 18.11 이상 18.11.3 미만 버전에서 발견되었습니다.

💡 쉬운 설명

GitLab 사용자가 대시보드 설정에 악의적인 코드를 삽입하면, 다른 사용자들이 그 대시보드를 볼 때 공격자의 코드가 실행되어 정보 탈취나 계정 탈취가 가능합니다. 높은 보안 위험도로 즉시 패치가 필요합니다.

🇺🇸 원문 (English)

GitLab has remediated an issue in GitLab EE affecting all versions from 18.7 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that, in customizable analytics dashboards, could have allowed an authenticated user to execute arbitrary JavaScript in the context of other users' browsers due to improper input sanitization.

📍 영향받는 시스템

GitLab EE 18.7-18.9.6, 18.10-18.10.5, 18.11-18.11.2

⚔️ 공격 벡터

Authenticated attacker injects malicious JavaScript into customizable analytics dashboard, executes in other users' browsers via Stored XSS

🛡️ 대응 방법

Upgrade GitLab EE to 18.9.7, 18.10.6, 18.11.3 or later

🔧 검증 코드

If version is 18.9.7 or higher (or 18.10.6+ or 18.11.3+), patched; otherwise vulnerable

Shell / Script
dpkg -l gitlab-ee 2>/dev/null | grep gitlab-ee | awk '{print $3}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

💻 영향받는 소프트웨어

Git