🔍 CVE-2026-75858

7.8
CVSS Score
HIGH
2026-08-18
2026-10-22 22:10
✅ 완료

🇰🇷 한글 설명

CodeWhale의 rlm_eval 도구에서 발생하는 원격 코드 실행 취약점입니다. rlm_eval 도구가 승인 요구 사항을 자동으로 처리하도록 설정되어 있어, 사용자의 승인 없이 모델이 제공한 임의의 파이썬 코드가 실행될 수 있습니다. 공격자는 프롬프트 인젝션을 통해 에이전트가 악성 코드를 실행하도록 유도할 수 있습니다.

💡 쉬운 설명

AI 도구가 사용자에게 물어보지 않고 마음대로 컴퓨터 명령어를 실행할 수 있는 보안 결함입니다. 해커가 보낸 특수한 메시지를 AI가 읽게 되면, 사용자의 허락 없이 컴퓨터를 조종할 수 있습니다.

🇺🇸 원문 (English)

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

📍 영향받는 시스템

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64

⚔️ 공격 벡터

신뢰할 수 없는 콘텐츠(웹 페이지, 파일 등)에 포함된 프롬프트 인젝션을 통한 원격 코드 실행

🛡️ 대응 방법

CodeWhale 버전을 0.8.64 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 결과의 버전이 0.8.41 이상 0.8.64 미만인지 확인하십시오.

Shell / Script
dpkg -l | grep -E 'codewhale|codewhale-tui' 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Python