🔍 CVE-2026-7647

8.1
CVSS Score
HIGH
2026-05-02
2026-05-05 19:15
✅ 완료

🇰🇷 한글 설명

WordPress의 Profile Builder Pro 플러그인 3.14.5 이하 버전에서 PHP 객체 주입 취약점이 발견되었습니다. 공격자가 제어하는 'args' POST 매개변수를 nonce 검증 없이 PHP의 maybe_unserialize() 함수로 처리하여 임의의 PHP 객체가 메모리에 주입될 수 있습니다. 이 AJAX 핸들러는 인증된 사용자와 미인증 사용자 모두 접근 가능하므로 완전히 인증되지 않은 공격자도 악용할 수 있습니다.

💡 쉬운 설명

WordPress 플러그인에서 사용자 입력을 제대로 검증하지 않아 악성 코드 객체를 삽입할 수 있는 보안 결함입니다. 누구나 이 결함을 악용하여 서버에 피해를 입힐 수 있습니다.

🇺🇸 원문 (English)

The Profile Builder Pro plugin for WordPress is vulnerable to PHP Object Injection in all versions up to and including 3.14.5. This is due to the use of PHP's maybe_unserialize() function on the attacker-controlled 'args' POST parameter within the wppb_request_users_pins_action_callback() AJAX handler, which lacked any nonce verification, type checking, or input validation before deserialization. Because the handler was registered with both wp_ajax_ and wp_ajax_nopriv_ hooks, it was reachable by completely unauthenticated users. This makes it possible for unauthenticated attackers to inject arbitrary PHP objects into application memory.

📍 영향받는 시스템

Profile Builder Pro plugin for WordPress versions up to and including 3.14.5

⚔️ 공격 벡터

Unauthenticated attacker sends crafted POST request to wp-admin/admin-ajax.php with serialized PHP object in 'args' parameter without nonce verification

🛡️ 대응 방법

Update Profile Builder Pro to version 3.14.6 or later, implement nonce verification, and add input validation before deserialization

🔧 검증 코드

If vulnerable version number (3.14.5 or earlier) is displayed, the plugin is vulnerable; no output means either plugin not installed or already patched

Shell / Script
grep -E 'Version: 3\.(1[0-4]\.|15\.)' /wp-content/plugins/profile-builder/profile-builder.php 2>/dev/null | head -1

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP