🔍 CVE-2026-78254

7.4
CVSS Score
HIGH
2026-09-07
2026-09-09 13:29
✅ 완료

🇰🇷 한글 설명

Apache Ant의 ftp 및 scp 작업에서 원격 서버로부터 파일을 다운로드할 때 경로 조작을 통해 지정된 디렉터리 외부로 파일을 쓸 수 있는 취약점입니다. 공격자가 악의적인 서버를 운영하거나 중간자 공격(MITM)을 수행할 경우, Ant를 실행하는 사용자의 권한으로 임의의 파일을 덮어쓸 수 있습니다.

💡 쉬운 설명

파일을 다운로드할 때 저장 위치를 마음대로 조작할 수 있는 허점이 있어, 해커가 시스템의 중요한 파일을 몰래 바꿀 수 있는 문제입니다. 이를 방지하려면 파일을 받는 서버가 안전한지 확인하고 최신 버전으로 업데이트해야 합니다.

🇺🇸 원문 (English)

The ftp and scp tasks of Apache Ant can download files from a remote server. A malicious server can provide relative paths that allow it to write outside of the dedicated target directory for the download, making it possible to overwrite files of the attacker's choice using the permissions of the user running Ant in versions prior to Ant 1.10.18. In order to exploit this vulnerability, the server would either have to be malicious or be subject to a machine-in-the-middle attack. Additionally in the case of scp or the ftp task using ftps the server must pass the server identity checks performed by the tasks. For ftp tasks not using ftps a malicious server could act as a machine-in-the-middle to provide malicious files. Starting with Ant 1.10.18 both tasks will prevent writing outside of the destination directory by default. An option is available to disable this behavior in the unlikely case that the old behavior is required by existing build files. Mitigations: Users of scp and ftp (when using ftps) in any version of Ant should not bypass server identity checks. Users of ftp not using ftps should switch to ftps where possible. All users are recommended to upgrade to Apache Ant 1.10.18, which fixes this issue.

📍 영향받는 시스템

Apache Ant 1.10.18 미만 버전

⚔️ 공격 벡터

악의적인 서버를 통한 상대 경로 조작 또는 중간자 공격(MITM)을 통한 파일 경로 변조

🛡️ 대응 방법

Apache Ant를 1.10.18 이상 버전으로 업그레이드하고, ftps 사용 시 서버 인증을 반드시 수행하며 일반 ftp 사용 시 ftps로 전환하십시오.

🔧 검증 코드

명령어 결과가 'Vulnerable'과 함께 1.10.18 미만 버전이 출력되면 취약한 상태이며, 'Safe'가 출력되면 안전한 상태입니다.

Shell / Script
ant -version 2>/dev/null | grep -E 'Apache Ant 1\.[0-9]+\.[0-9]+' | awk '{print $3}' | awk -F. '$3 < 18 {print "Vulnerable"; print $0; exit} $3 >= 18 {print "Safe"; print $0; exit}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

💻 영향받는 소프트웨어

Minecraft Bedrock Dedicated Server