🔍 CVE-2026-80190

6.1
CVSS Score
MEDIUM
2026-09-04
2026-09-08 14:00
✅ 완료

🇰🇷 한글 설명

Apache Allura의 SVN 코드 저장소를 통해 저장형 XSS(Cross-Site Scripting) 취약점이 발생합니다. Git 저장소는 영향을 받지 않는 것으로 알려져 있으며, 기본 CSP 헤더를 통해 완화될 가능성이 있습니다.

💡 쉬운 설명

해커가 SVN 저장소에 악성 코드를 심어두면, 해당 페이지를 보는 사용자의 브라우저에서 코드가 실행될 수 있는 보안 약점입니다. 다행히 Git 저장소를 사용하는 경우에는 문제가 발생하지 않습니다.

🇺🇸 원문 (English)

Apache Allura: stored XSS via SVN code repositories.  Git repositories are not known to be affected.  The vulnerability is likely mitigated via default CSP headers. This issue affects Apache Allura: through 1.20.0. Users are recommended to upgrade to version 1.21.0, which fixes the issue.

📍 영향받는 시스템

Apache Allura 1.20.0 및 그 이전 버전 (SVN 저장소 사용 시)

⚔️ 공격 벡터

SVN 코드 저장소에 악성 스크립트를 삽입하여 사용자의 브라우저에서 실행시키는 방식

🛡️ 대응 방법

Apache Allura를 취약점이 해결된 1.21.0 버전 이상으로 업그레이드하십시오.

🔧 검증 코드

출력된 버전 번호가 1.21.0 미만인지 확인하여 취약 여부를 판단합니다.

Shell / Script
python3 -c "import allura; print(allura.__version__)" 2>/dev/null || echo 'Version not found via python module'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

Git