🔍 CVE-2026-8145

5.4
CVSS Score
MEDIUM
2026-10-15
2026-10-15 14:45
✅ 완료

🇰🇷 한글 설명

WordPress용 WholesaleX – B2B & Wholesale Plugin의 모든 버전(3.0.8 포함)에서 권한 상승 취약점이 발견되었습니다. 'process_registration' 과정 중 'wholesalex_registration_role' 매개변수에 대한 검증이 누락되어, 인증되지 않은 공격자가 원하는 WholesaleX 역할로 등록될 수 있습니다.

💡 쉬운 설명

회원가입 시 자신이 원하는 등급(예: 도매 회원)을 마음대로 선택할 수 있는 보안 결함입니다. 이를 통해 공격자는 일반 사용자가 아닌 높은 권한을 가진 사용자로 위장할 수 있습니다.

🇺🇸 원문 (English)

The WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 3.0.8 via the 'process_registration' due to missing validation on the 'wholesalex_registration_role' parameter. This makes it possible for unauthenticated attackers to register as any existing WholesaleX role. The vulnerability was partially patched in version 2.3.8.

📍 영향받는 시스템

WholesaleX – B2B & Wholesale Plugin for WooCommerce (3.0.8 이하 모든 버전)

⚔️ 공격 벡터

회원가입 요청 시 'wholesalex_registration_role' 매개변수를 조작하여 전송

🛡️ 대응 방법

플러그인을 최신 버전으로 업데이트하거나 보안 패치가 적용된 버전 이상을 사용하십시오.

🔧 검증 코드

출력된 플러그인 버전이 3.0.8 이하인지 확인하여 취약 여부를 판단합니다.

Shell / Script
wp plugin list --status=active | grep -i 'wholesalex' && wp plugin list --all | grep -E 'wholesalex' | awk '{print $2 " version: " $3}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

💻 영향받는 소프트웨어

WordPress