🔍 CVE-2026-81719

7.8
CVSS Score
HIGH
2026-08-27
2026-09-02 13:15
✅ 완료

🇰🇷 한글 설명

openssl_encrypt 1.4.9 미만 버전에서 서명되지 않은 제3자 플러그인을 실행할 때 보안 통제가 불충분하여 발생하는 취약점입니다. 플러그인 서명 정책이 기본적으로 경고(WARN)로 설정되어 있어, 런타임 샌드박스가 설치되기 전 단계에서 검증되지 않은 플러그인이 호스트 프로세스 내에서 실행될 수 있습니다. 이를 통해 공격자는 사용자 권한으로 임의의 코드를 실행할 수 있습니다.

💡 쉬운 설명

검증되지 않은 외부 플러그인을 불러올 때 보안 검사가 제대로 이루어지지 않아 발생하는 문제입니다. 공격자가 만든 가짜 플러그인을 실행하게 유도하면 컴퓨터를 마음대로 조종할 수 있습니다.

🇺🇸 원문 (English)

openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.

📍 영향받는 시스템

openssl_encrypt 1.4.9 미만 모든 버전

⚔️ 공격 벡터

사용자가 악성 플러그인을 로드하도록 유도하여 런타임 샌드박스 실행 전 임의 코드 실행

🛡️ 대응 방법

openssl_encrypt를 1.4.9 이상 버전으로 업데이트하여 서명 정책을 ENFORCE로 적용

🔧 검증 코드

출력된 버전이 1.4.9 미만인 경우 해당 취약점에 노출된 상태입니다.

Shell / Script
openssl_encrypt --version 2>/dev/null | grep -E '1\.[4-9]\.'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

OpenSSL