🔍 CVE-2026-84315

8.3
CVSS Score
HIGH
2026-10-12
2026-10-13 16:17
✅ 완료

🇰🇷 한글 설명

Nginx UI 2.4.1 미만 버전에서 다중 인증(OTP)이 활성화된 사용자라도 특정 민감한 경로에 대해 보안 세션 검증(RequireSecureSession)이 누락되는 취약점이 존재합니다. 이로 인해 탈취된 인증 세션을 이용하면 OTP나 패스키 단계 없이도 백업, DNS 설정, 인증서 및 사이트 자동화 설정을 임의로 변경할 수 있습니다.

💡 쉬운 설명

로그인 세션을 해커가 훔쳤을 경우, 추가 보안 단계인 OTP(일회용 비밀번호)를 거치지 않고도 서버의 중요한 설정을 마음대로 바꿀 수 있는 문제입니다. 해커가 관리자 권한을 악용해 백업 파일을 만들거나 DNS 설정을 조작할 위험이 있습니다.

🇺🇸 원문 (English)

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, Nginx UI does not apply RequireSecureSession to multiple authenticated mutation routes even though OTP-enabled users are expected to present a fresh X-Secure-Session-ID for sensitive actions. A stolen authenticated session can therefore create or alter automatic backups, DNS credentials and records, certificates and ACME users, Nginx control settings, and site or stream automation without completing the OTP or passkey step-up. This issue is fixed in version 2.4.1.

📍 영향받는 시스템

Nginx UI 버전 2.4.1 미만

⚔️ 공격 벡터

탈취된 인증 세션을 사용하여 OTP 검증이 누락된 민감한 API 경로에 직접 요청을 보내는 방식

🛡️ 대응 방법

Nginx UI를 최신 버전인 2.4.1 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 정보가 2.4.1 미만인 경우 해당 취약점에 노출된 상태입니다.

Shell / Script
curl -s http://<NGINX_UI_URL>/version | grep -E '2\.[0-4]\.'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H

💻 영향받는 소프트웨어

Nginx