🔍 CVE-2026-84316

8.8
CVSS Score
HIGH
2026-10-12
2026-10-13 15:17
✅ 완료

🇰🇷 한글 설명

Nginx UI 2.4.1 미만 버전에서 설정 검증 로직의 결함으로 인해 발생하는 취약점입니다. 공격자가 한 줄에 여러 명령어를 배치하여 검증을 우회하고, load_module이나 js_import와 같은 제한된 지시어를 삽입하여 Nginx 워커 컨텍스트에서 코드를 실행할 수 있습니다.

💡 쉬운 설명

Nginx 설정 화면에서 보안 검사를 피해서 위험한 명령어를 몰래 끼워 넣을 수 있는 문제입니다. 이를 통해 해커가 서버에서 원하지 않는 프로그램을 실행할 위험이 있습니다.

🇺🇸 원문 (English)

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, config.ValidateConfigDirectives splits configuration by newline and checks only the first directive token on each line even though Nginx permits multiple semicolon-separated directives on one line. An authenticated caller can place a benign directive first and a restricted load_module, js_import, perl, or user root directive later on the same line, or can use an unrestricted include directive to load restricted content. These mechanisms bypass validation on REST, nginx_config_modify, site, and stream write paths; when an executable module is available, the injected configuration can execute code in the Nginx worker context. This issue is fixed in version 2.4.1.

📍 영향받는 시스템

Nginx UI 버전 2.4.1 미만

⚔️ 공격 벡터

인증된 사용자가 한 줄에 정상적인 명령어와 제한된 명령어를 함께 작성하여 검증 로직을 우회함

🛡️ 대응 방법

Nginx UI를 최신 버전인 2.4.1 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 정보가 2.4.1 미만인지 확인하십시오.

Shell / Script
nginx-ui --version 2>/dev/null || dpkg -l | grep nginx-ui 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Nginx