🔍 CVE-2026-84360

8.1
CVSS Score
HIGH
2026-10-12
2026-10-13 14:31
✅ 완료

🇰🇷 한글 설명

Nginx UI 2.4.1 미만 버전에서 HTTP 설정 변경 경로가 보안 세션 요구 사항을 우회하는 취약점이 발견되었습니다. OTP를 사용하는 사용자라도 유효한 X-Secure-Session-ID 없이 MCP 경로를 통해 Nginx 설정을 생성, 수정 및 재로드할 수 있습니다. 이 문제는 2.4.1 버전에서 수정되었습니다.

💡 쉬운 설명

보안이 강화된 추가 인증 단계가 있어야 하는 설정 변경 기능이 특정 경로를 통해 제대로 작동하지 않는 문제입니다. 이로 인해 일반 권한을 가진 사용자가 관리자처럼 서버 설정을 마음대로 바꾸고 적용할 수 있습니다.

🇺🇸 원문 (English)

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.

📍 영향받는 시스템

Nginx UI 2.4.1 미만 모든 버전

⚔️ 공격 벡터

인증된 사용자가 보안 세션 없이 /mcp 및 /mcp_message 경로를 호출하여 설정 변경 API 실행

🛡️ 대응 방법

Nginx UI를 최신 버전인 2.4.1 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 정보가 2.4.1 미만(예: 2.4.0 이하)이면 취약한 상태입니다.

Shell / Script
curl -s http://<target_ip>/version | grep -E '2\.[0-4]\.'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

💻 영향받는 소프트웨어

Nginx