🔍 CVE-2026-85248

5.9
CVSS Score
MEDIUM
2026-10-19
2026-10-19 20:45
✅ 완료

🇰🇷 한글 설명

Apache Camel PQC 컴포넌트에서 공유 자원을 적절한 동기화 없이 동시에 실행하여 발생하는 레이스 컨디션(Race Condition) 취약점입니다. 단일 java.security.Signature 인스턴스를 여러 스레드가 공유함으로써 서명 검증 데이터가 서로 뒤섞여 잘못된 검증 결과가 발생할 수 있습니다.

💡 쉬운 설명

여러 명의 사용자가 동시에 요청을 보낼 때, 보안 검사 도구가 데이터를 섞어서 처리하는 문제입니다. 이로 인해 실제로는 잘못된 서명임에도 불구하고 정상적인 것으로 잘못 판단될 위험이 있습니다.

🇺🇸 원문 (English)

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Camel PQC component. This issue affects Apache Camel: from 4.12.0 before 4.18.5, from 4.19.0 before 4.22.1. The producer held a single java.security.Signature instance and used it for every exchange without synchronizing access. Signature is stateful and is not thread safe: update() accumulates the data to be signed or verified, and verify() consumes that accumulated state. With concurrent exchanges sharing one instance the update and verify calls of different messages interleave, so a verification can complete against data that belongs to another exchange, or against a partially accumulated buffer. The outcome is non-deterministic and includes a verification reporting success for a message whose signature was never actually checked, which defeats the guarantee the component exists to provide. Reaching it requires concurrent traffic through the same endpoint, which is the ordinary condition for a Camel route under load. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The Signature instance is no longer shared across concurrent exchanges. For deployments that cannot upgrade immediately, restrict the affected route to a single concurrent consumer so that no two exchanges use the instance at once.

📍 영향받는 시스템

Apache Camel 4.12.0 ~ 4.18.4, 4.19.0 ~ 4.22.0

⚔️ 공격 벡터

동일한 엔드포인트로 다수의 트래픽을 동시에 전송하여 서명 검증 로직의 동기화 오류 유도

🛡️ 대응 방법

Apache Camel 4.23.0, 4.18.5 또는 4.22.1 버전으로 업그레이드

🔧 검증 코드

출력된 결과에 취약한 버전 범위가 포함되어 있다면 해당 버전이 설치된 상태입니다.

Shell / Script
mvn dependency:tree | grep 'camel-core' | grep -E '4\.(12|19|20|21|22)\.'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

💻 영향받는 소프트웨어

IBM Security Verify Access