🔍 CVE-2026-85251

7.5
CVSS Score
HIGH
2026-10-19
2026-10-19 20:45
✅ 완료

🇰🇷 한글 설명

Apache Camel HTTP 컴포넌트에서 인증 정보가 권한이 없는 외부 호스트로 노출되는 취약점입니다. followRedirects=true 설정 시, 리다이렉트 과정에서 OAuth2 Bearer 토큰이나 Basic/Digest 인증 정보가 공격자가 제어하는 호스트로 재전송될 수 있습니다.

💡 쉬운 설명

인터넷 주소가 자동으로 바뀌는 과정에서 사용자의 비밀번호나 인증 키가 엉뚱한 사이트로 전달될 수 있는 문제입니다. 공격자가 만든 사이트로 연결되도록 유도하면 사용자의 중요한 정보를 가로챌 수 있습니다.

🇺🇸 원문 (English)

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Camel HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. Two paths handed credentials to a redirect target, which is a host chosen by the remote server rather than by the route, once followRedirects=true. OAuth2ClientConfigurer registers its interceptor with addRequestInterceptorFirst, and HttpClient runs protocol-level request interceptors inside ProtocolExec, which sits below RedirectExec in the exec chain; the interceptor therefore ran again for every redirect hop and re-attached Authorization: Bearer to whatever host the Location header named. Separately, credentials were registered against an AuthScope matching any host, so basic and digest credentials were presented to a redirect target as well. A remote endpoint - or anyone who can influence its responses - could therefore collect the bearer token or the configured credentials simply by answering with a redirect to a host it controls. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. Credentials are now sent only to the authority the endpoint was configured with, and are not re-attached when a redirect crosses to another host. For deployments that cannot upgrade immediately, set followRedirects=false on endpoints that carry credentials, and handle any redirect explicitly in the route so that the destination is chosen by the route rather than by the remote server.

📍 영향받는 시스템

Apache Camel 4.0.0 ~ 4.18.4, 4.19.0 ~ 4.22.0

⚔️ 공격 벡터

원격 서버가 Location 헤더를 통해 공격자가 제어하는 호스트로 리다이렉트를 유도하여 인증 정보를 탈취

🛡️ 대응 방법

Apache Camel을 4.23.0, 4.18.5 또는 4.22.1 이상 버전으로 업그레이드하거나, 인증이 필요한 엔드포인트에서 followRedirects=false로 설정

🔧 검증 코드

명령어 결과에 취약한 버전 범위의 Apache Camel 라이브러리가 나타나면 해당 취약점에 노출된 상태입니다.

Shell / Script
mvn dependency:tree | grep -E 'camel-http|camel-core' | grep -E '4\.(0\.[0-9]|1[8-9]\.[0-4]|2[0-2]\.[0-1])'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

Apache HTTP Server