🔍 CVE-2026-85260

5.5
CVSS Score
MEDIUM
2026-10-19
2026-11-03 21:32
✅ 완료

🇰🇷 한글 설명

Apache Camel의 MLLP 컴포넌트에서 민감한 정보가 로그 파일에 삽입되는 취약점이 발견되었습니다. logPhi 옵션이 기본적으로 true로 설정되어 있어 환자의 의료 정보(PHI)가 로그에 기록될 수 있으며, 옵션을 꺼두더라도 특정 경로에서는 데이터가 계속 로그에 남는 문제가 있습니다.

💡 쉬운 설명

의료 데이터를 다루는 프로그램이 환자의 개인정보를 보안이 취약한 일반 로그 파일에 그대로 적어버리는 문제입니다. 이로 인해 로그를 볼 수 있는 사람이 환자의 민감한 정보를 쉽게 볼 수 있게 됩니다.

🇺🇸 원문 (English)

Insertion of Sensitive Information into Log File vulnerability in Apache Camel MLLP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The camel-mllp component carries a logPhi option that governs whether HL7 payload content may be written to the log. It defaulted to true, so a deployment that did nothing logged protected health information out of the box. Two further paths wrote payload content to the log regardless of the setting, so even an operator who had turned logPhi off was still exposed on those paths. MLLP is used to carry HL7 clinical messages, so the content concerned is patient data, and it reached ordinary application logs where it is subject to whatever retention, aggregation and access the deployment applies to logs generally rather than to clinical records. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. logPhi now defaults to false and is honoured on the paths that previously ignored it. This is a changed default: a deployment that relied on payload logging must now set logPhi=true explicitly. Because the upgrade guide for a change like this lives on the main branch only, operators upgrading within the 4.18.x or 4.22.x lines should treat this advisory as the notice of that change. For deployments that cannot upgrade immediately, set logPhi=false and be aware that two paths will continue to log payload content until the fix is applied; restrict access to the logs accordingly.

📍 영향받는 시스템

Apache Camel 4.0.0 ~ 4.18.4, 4.19.0 ~ 4.22.0

⚔️ 공격 벡터

직접적인 공격보다는 설정 오류로 인해 민감한 데이터가 로그에 노출되는 정보 유출 형태입니다.

🛡️ 대응 방법

Apache Camel을 4.23.0(또는 4.18.5, 4.22.1 이상) 버전으로 업그레이드하십시오.

🔧 검증 코드

출력된 Apache Camel의 버전이 취약한 범위(4.0.0~4.18.4 또는 4.19.0~4.22.0)에 해당하는지 확인합니다.

Shell / Script
mvn dependency:list | grep 'camel-core' | grep -E '4\[0-9]\.[0-9]\.[0-9]\]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N