🇰🇷 한글 설명
Apache Tomcat Native의 TLS 핸드셰이크 과정에서 발생하는 버퍼 오버리드 취약점입니다. 공격자가 이를 악용할 경우 JVM 크래시를 유발하여 서비스 거부(DoS) 상태를 만들 수 있습니다.
💡 쉬운 설명
서버와 통신을 시작하는 단계에서 데이터 범위를 잘못 읽는 오류가 발생합니다. 이를 통해 공격자가 서버 프로그램을 강제로 종료시켜 서비스를 중단시킬 수 있습니다.
🇺🇸 원문 (English)
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.
This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected.
Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
📍 영향받는 시스템
Apache Tomcat Native 1.3.0 ~ 1.3.8 및 2.0.0 ~ 2.0.15
⚔️ 공격 벡터
TLS 핸드셰이크 과정 중 조작된 데이터를 전송하여 JVM 크래시 유도
🛡️ 대응 방법
Apache Tomcat Native를 1.3.9 또는 2.0.16 이상 버전으로 업그레이드
🔧 검증 코드
출력된 라이브러리 경로를 통해 설치된 버전을 확인하거나 패키지 관리자로 버전을 체크합니다.
ldconfig -p | grep tomcat_native