🇰🇷 한글 설명
Apache Tomcat Native의 스레드 내 레이스 컨디션(Race Condition) 취약점으로 인해 특정 설정에서 클라이언트 인증서 검증 요구 사항이 강제로 낮아질 수 있습니다. 이로 인해 보안 설정이 무력화될 위험이 있습니다.
💡 쉬운 설명
여러 작업이 동시에 처리되는 과정에서 발생하는 충돌로 인해, 원래는 반드시 확인해야 하는 사용자 인증 절차를 건너뛰게 만들 수 있는 보안 결함입니다. 인증서 확인 과정을 우회하여 허가되지 않은 사용자가 접근할 가능성이 있습니다.
🇺🇸 원문 (English)
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations.
This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected.
Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
📍 영향받는 시스템
Apache Tomcat Native 2.0.0 ~ 2.0.15, 1.3.0 ~ 1.3.8 및 지원되지 않는 이전 버전
⚔️ 공격 벡터
스레드 간의 실행 순서 차이를 이용한 레이스 컨디션 공격을 통해 인증 절차 우회
🛡️ 대응 방법
Apache Tomcat Native를 2.0.16 또는 1.3.9 이상의 버전으로 업그레이드하십시오.
🔧 검증 코드
설치된 Apache Tomcat Native의 버전을 확인하여 취약한 범위(2.0.0-2.0.15 또는 1.3.0-1.3.8)에 해당하는지 확인합니다.
apr-util --version 2>/dev/null || tomcat-native-version-check-command 2>/dev/null