🔍 CVE-2026-87018

7.5
CVSS Score
HIGH
2026-10-15
2026-10-19 20:41
✅ 완료

🇰🇷 한글 설명

Node.js용 HTTP 클라이언트 라이브러리인 undici의 특정 버전에서 TLS 1.2 재협상 시 호스트네임 불일치 오류가 발생하면 프로세스가 충돌하는 취약점이 발견되었습니다. 공격자가 제어하는 HTTPS 엔드포인트가 재협상을 통해 유효하지만 호스트네임이 다른 인증서를 제시할 경우, undici의 에러 핸들러가 이를 처리하지 못해 Node.js 프로세스가 즉시 종료됩니다.

💡 쉬운 설명

악의적인 웹사이트에 접속할 때, 해당 사이트가 갑자기 인증서를 바꾸면 프로그램이 오류를 견디지 못하고 강제로 꺼져버리는 문제입니다. 이를 통해 공격자는 서비스 전체를 중단시키는 공격을 수행할 수 있습니다.

🇺🇸 원문 (English)

undici is an HTTP client library for Node.js. In versions 4.2.1 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, the client process crashes when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with a certificate-altname error, but undici's established-socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught assertion that terminates the Node.js process, affecting both the HTTP/1.1 and HTTP/2 paths. A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process, and exploitation needs no CA compromise because the attacker controls the endpoint and can present two ordinary valid certificates. Only TLS 1.2 is affected, since TLS 1.3 does not support renegotiation. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, restrict outbound connections to TLS 1.3 so renegotiation cannot occur, when the target endpoints support it.

📍 영향받는 시스템

undici 4.2.1-6.29.0, 7.0.0-7.30.0, 8.0.0-8.12.1

⚔️ 공격 벡터

악의적인 HTTPS 서버가 TLS 1.2 재협상을 유도하여 호스트네임이 일치하지 않는 인증서를 제시함으로써 클라이언트 프로세스를 강제 종료함

🛡️ 대응 방법

undici를 6.29.1, 7.30.1 또는 8.12.2 이상의 버전으로 업데이트하거나, 가능한 경우 TLS 1.3만 사용하도록 제한함

🔧 검증 코드

출력된 undici의 버전이 취약한 범위(4.2.1-6.29.0, 7.0.0-7.30.0, 8.0.0-8.12.1)에 포함되는지 확인합니다.

Shell / Script
npm list undici | grep undici

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Node.js