🇰🇷 한글 설명
Apache Tomcat에서 per-message-deflate 기능 사용 시 길이 매개변수 처리의 불일치로 인해 발생하는 취약점입니다. 이로 인해 WebSocket 메시지 스머글링(smuggling) 공격이 가능해질 수 있습니다.
💡 쉬운 설명
웹사이트와 서버가 데이터를 주고받는 통로에서 데이터의 길이를 잘못 계산하여 발생하는 문제입니다. 공격자가 몰래 숨겨진 메시지를 끼워 넣어 서버를 교란할 수 있습니다.
🇺🇸 원문 (English)
Improper handling of length parameter inconsistency vulnerability in Apache Tomcat allows WebSocket message smuggling when per-message-deflate is used.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121.
The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.56 through 7.0.109. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.1.22, which fix the issue.
📍 영향받는 시스템
Apache Tomcat 11.0.0-M1~11.0.25, 10.1.0-M1~10.1.59, 9.0.0.M1~9.0.121, 8.5.0~8.5.100, 7.0.56~7.0.109
⚔️ 공격 벡터
WebSocket의 per-message-deflate 압축 기능을 이용한 메시지 길이 불일치 유도 및 데이터 삽입
🛡️ 대응 방법
Apache Tomcat을 11.0.26, 10.1.60 또는 9.1.22 이상의 최신 버전으로 업그레이드하십시오.
🔧 검증 코드
출력된 Tomcat 버전이 취약한 버전 범위에 포함되는지 확인하십시오.
java -jar tomcat-version-check.jar || find / -name 'catalina.jar' -exec grep -H 'Version' {} \; 2>/dev/null
🇰🇷 KISA(한국인터넷진흥원) 보안 권고
이 CVE에 대한 한국 공식 권고 (1건)
Apache 제품 보안 업데이트 권고
P4
📅 2026-09-30 · sec_notice
Apache Tomcat 제품에서 인증 우회 및 HTTP 요청 스머글링 등 다수의 보안 취약점이 발견되었습니다. 해당 제품의 특정 버전을 사용하는 사용자는 보안 위협 방지를 위해 반드시 최신 버전으로 업데이트해야 합니다.