🔍 CVE-2026-88974

5.4
CVSS Score
MEDIUM
2026-09-23
2026-09-23 18:12
✅ 완료

🇰🇷 한글 설명

WPGraphQL 2.22.2 미만 버전에서 updatePost 뮤테이션이 객체 수준의 권한을 제대로 검증하지 않는 취약점이 발견되었습니다. 이로 인해 인증된 기여자(Contributor) 권한을 가진 사용자가 편집자의 승인 없이 자신의 초안을 게시하거나, 권한이 없는 상태에서 이미 게시된 자신의 글을 수정할 수 있습니다.

💡 쉬운 설명

글을 쓸 권한만 있는 일반 사용자가 관리자의 허락 없이 글을 바로 발행하거나 수정할 수 있는 보안 허점입니다. 이로 인해 사이트에 원치 않는 게시물이 올라올 위험이 있습니다.

🇺🇸 원문 (English)

WPGraphQL provides a GraphQL API for WordPress sites. Prior to 2.22.2, the updatePost mutation in src/Mutation/PostObjectUpdate.php checks only the collection-level edit_posts capability and the post author, but does not enforce the object-level edit_post capability or require publish_posts for public status transitions. An authenticated Contributor can therefore publish the Contributor's own draft without editorial approval or modify the Contributor's previously published post despite lacking edit_published_posts, while posts owned by other authors remain protected. This issue is fixed in version 2.22.2.

📍 영향받는 시스템

WPGraphQL 2.22.2 미만 버전

⚔️ 공격 벡터

인증된 기여자(Contributor) 계정을 이용한 GraphQL API(updatePost mutation) 호출

🛡️ 대응 방법

WPGraphQL 플러그인을 2.22.2 버전 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 wpgraphql의 버전이 2.22.2 미만인지 확인하십시오.

Shell / Script
wp plugin list --allow-root | grep -E 'wpgraphql'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L