🔍 CVE-2026-9106

5.5
CVSS Score
MEDIUM
2026-06-30
2026-10-25 21:10
✅ 완료

🇰🇷 한글 설명

GitHub Enterprise Server에서 UI 오표기 취약점이 발견되어, OAuth 애플리케이션이 조직의 러너 관리 권한을 의도치 않게 획득할 수 있습니다. 공격자는 권한 범위(scope)가 표시되지 않는 점을 악용하여 사용자의 승인을 유도함으로써 조직의 러너 관리 권한을 탈취할 수 있습니다.

💡 쉬운 설명

사용자가 앱에 권한을 줄 때 어떤 권한을 주는지 화면에 제대로 나타나지 않는 문제입니다. 이를 통해 공격자는 사용자가 모르는 사이에 조직의 중요한 관리 권한을 몰래 가져갈 수 있습니다.

🇺🇸 원문 (English)

A UI misrepresentation vulnerability was identified in GitHub Enterprise Server that allowed an OAuth application to gain unintended access to an organization's runner management. An attacker could exploit this by creating an OAuth application requesting the manage_runners:org scope and directing a victim user to authorize it, as the scope was not displayed on the authorization consent screen. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.21.2, 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20. This vulnerability was reported via the GitHub Bug Bounty program.

📍 영향받는 시스템

GitHub Enterprise Server 3.22 미만 모든 버전

⚔️ 공격 벡터

권한 범위가 표시되지 않는 UI 허점을 이용해 사용자가 악성 OAuth 애플리케이션을 승인하도록 유도

🛡️ 대응 방법

GitHub Enterprise Server를 수정된 버전(3.21.2, 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20 중 하나)으로 업데이트

🔧 검증 코드

출력된 버전 정보가 취약점이 해결된 패치 버전 이상인지 확인합니다.

Shell / Script
curl -s http://<your-github-enterprise-url>/api/v3/connection | grep -E 'version'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L