🔍 CVE-2026-92415

5.3
CVSS Score
MEDIUM
2026-10-07
2026-10-13 14:24
✅ 완료

🇰🇷 한글 설명

Apache Jackrabbit의 WebDAV/Davex 클라이언트에서 외부 제어 입력이 클래스나 코드를 선택하는 데 사용되는 취약점이 발견되었습니다. 악의적인 서버나 중간자 공격자가 클라이언트의 클래스패스에 있는 임의의 클래스를 인스턴스화하도록 유도하여 임의의 파일을 생성하거나 내용을 잘라낼 수 있습니다.

💡 쉬운 설명

해커가 조작된 서버를 통해 사용자의 컴퓨터에 원치 않는 프로그램을 실행하거나 파일을 망가뜨릴 수 있는 보안 약점입니다. Jackrabbit을 사용하여 원격 저장소에 연결하는 프로그램이 이 공격에 노출될 수 있습니다.

🇺🇸 원문 (English)

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

📍 영향받는 시스템

Apache Jackrabbit 2.23.0-2.23.5, 2.22.0-2.22.4, 2.20.0-2.20.17

⚔️ 공격 벡터

악의적인 WebDAV/DavEx 서버를 통한 클래스 인스턴스화 유도 또는 중간자 공격(MITM)

🛡️ 대응 방법

Apache Jackrabbit 버전을 2.23.6, 2.22.5 또는 2.20.18 이상으로 업그레이드하십시오.

🔧 검증 코드

출력된 결과에서 Jackrabbit JAR 파일의 버전이 취약한 범위(2.23.0-2.23.5 등)에 포함되는지 확인하십시오.

Shell / Script
find / -name "jackrabbit*.jar" 2>/dev/null | xargs grep -H "Implementation-Version" 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

💻 영향받는 소프트웨어

IBM WebSphere Application Server