🇰🇷 한글 설명
PostgreSQL 오픈소스 확장 프로그램인 pgcollection 2.0.0부터 2.1.1 버전에서 타입 혼동(Type Confusion) 취약점이 발견되었습니다. 인증된 원격 사용자가 조작된 SQL 문을 통해 컬렉션 값 검색 및 배열 변환 함수 간의 메타데이터 불일치를 악용하여 postgres 운영체제 사용자의 권한으로 임의 코드를 실행할 수 있습니다.
💡 쉬운 설명
데이터의 형식을 잘못 처리하는 오류를 이용해 해커가 데이터베이스 서버에 몰래 명령을 내릴 수 있는 문제입니다. 공격자가 성공하면 데이터베이스 관리자 권한을 탈취하여 시스템을 마음대로 조작할 수 있습니다.
🇺🇸 원문 (English)
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions.
To remediate this issue, users should upgrade to version 2.1.2 or later.
📍 영향받는 시스템
pgcollection 2.0.0 ~ 2.1.1
⚔️ 공격 벡터
인증된 사용자가 조작된 SQL 문을 실행하여 타입 메타데이터 불일치를 유도함
🛡️ 대응 방법
pgcollection을 2.1.2 버전 이상으로 업그레이드하십시오.
🔧 검증 코드
출력된 버전 번호가 2.1.2 미만(2.0.0~2.1.1)이면 취약한 상태입니다.
psql -c "SELECT extversion FROM pg_extension WHERE extname = 'pgcollection';" 2>/dev/null