🔍 CVE-2026-97693

9.9
CVSS Score
CRITICAL
2026-11-04
2026-11-04 22:18
✅ 완료

🇰🇷 한글 설명

Yuxi(대규모 모델 기반 지능형 지식베이스 및 지식그래프 에이전트 플랫폼)의 0.6.0.beta1부터 0.7.1 이전 버전에서는 명령 실행이 가능한 Docker 샌드박스와 신뢰된 애플리케이션 서비스 간 격리가 불충분합니다. 낮은 권한의 인증된 사용자가 다른 테넌트의 샌드박스 API에 접근해 파일과 시크릿을 탈취하고, 명령을 실행하거나 샌드박스를 생성·삭제할 수 있으며, 기본 내부 서비스 자격 증명이 변경되지 않은 경우 PostgreSQL 등을 통해 추가 명령 실행까지 가능합니다.

💡 쉬운 설명

일반 사용자 계정으로도 다른 사용자의 작업 공간에 접근해 데이터를 보거나 바꾸고 서비스를 중단시킬 수 있는 심각한 취약점입니다. 기본 설정 비밀번호를 그대로 쓰고 있다면 더 큰 피해가 생길 수 있습니다.

🇺🇸 원문 (English)

Yuxi is a large-model-based intelligent knowledge base and knowledge graph agent development platform. From 0.6.0.beta1 until 0.7.1, there is insufficient isolation between execution-capable Docker sandboxes and trusted application services. A low-privileged authenticated user who can execute commands in their own sandbox can reach other tenants' sandbox APIs, access their files and secrets, execute commands in active sandboxes, and enumerate, create, or delete sandboxes through the unauthenticated provisioner without knowing administrator, database, or MinIO credentials. Sandboxes can also reach shared internal services; if shipped default service credentials remain unchanged, an attacker can use them, and if the exposed PostgreSQL account is a superuser, obtain command execution in the PostgreSQL container. These paths can disclose or modify cross-tenant data and sandbox state or cause denial of service through sandbox deletion without a container escape or kernel vulnerability. This vulnerability is fixed in 0.7.1. Existing deployments must separately rotate persisted PostgreSQL, Neo4j, or MinIO credentials that were previously set to documented or shipped defaults because upgrading the Compose files does not automatically rotate them.

📍 영향받는 시스템

Yuxi 0.6.0.beta1 ~ 0.7.1 미만 버전

⚔️ 공격 벡터

인증된 낮은 권한 사용자가 자신의 샌드박스에서 명령을 실행한 뒤 내부 샌드박스 API와 공유 내부 서비스(기본 자격 증명 사용 시 PostgreSQL 등)에 접근

🛡️ 대응 방법

Yuxi 0.7.1 이상으로 업그레이드하고, 기존 배포의 PostgreSQL·Neo4j·MinIO 기본 자격 증명을 즉시 변경

🔧 검증 코드

Yuxi 이미지 태그가 0.7.1 이상이면 패치된 버전이며, 0.7.1 미만이거나 결과가 없으면 버전을 직접 확인 후 취약 여부를 판단하고, 기본 자격 증명 사용 여부도 별도로 점검해야 합니다.

Shell / Script
docker ps --format '{{.Image}}' 2>/dev/null | grep -i yuxi

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

💻 영향받는 소프트웨어

PostgreSQL Docker